Current filter:
                                You should refresh the page.
                                  • I got this error when scrolling the grid:
                                    [Intervention] Unable to preventDefault inside passive event listener due to target being treated as passive.
                                    from devexpress: it was fixed in 19.1.3
                                    https://www.devexpress.com/Support/Center/Question/Details/T724265/scroll-the-unable-to-preventdefault-inside-passive-event-listener-due-to-target-being
                                    however my devexpress version is 19.1.7.
                                    /**
                                     * DevExtreme (events/core/events_engine.js)
                                     * Version: 19.1.7
                                     * Build date: Fri Oct 11 2019
                                     *
                                     * Copyright (c) 2012 - 2019 Developer Express Inc. ALL RIGHTS RESERVED
                                     * Read about DevExtreme licensing here: https://js.devexpress.com/Licensing/
                                     */
                                    ...

                                    [JavaScript]
                                    initEvent(normalizeEventArguments(function(src, config) { var that = this; var propagationStopped = false; var immediatePropagationStopped = false; var defaultPrevented = false; extend(that, src); if (src instanceof eventsEngine.Event || windowUtils.hasWindow() && src instanceof window.Event) { that.originalEvent = src; that.currentTarget = void 0 } if (!(src instanceof eventsEngine.Event)) { extend(that, { isPropagationStopped: function() { return !!(propagationStopped || that.originalEvent && that.originalEvent.propagationStopped) }, stopPropagation: function() { propagationStopped = true; that.originalEvent && that.originalEvent.stopPropagation() }, isImmediatePropagationStopped: function() { return immediatePropagationStopped }, stopImmediatePropagation: function() { this.stopPropagation(); immediatePropagationStopped = true; that.originalEvent && that.originalEvent.stopImmediatePropagation() }, isDefaultPrevented: function() { return !!(defaultPrevented || that.originalEvent && that.originalEvent.defaultPrevented) }, preventDefault: function() { defaultPrevented = true; that.originalEvent && that.originalEvent.preventDefault() // ERROR } }) } addProperty("which", calculateWhich, that); if (0 === src.type.indexOf("touch")) { delete config.pageX; delete config.pageY } extend(that, config); that.guid = ++guid }));

                                    error at row

                                    [JavaScript]
                                    preventDefault: function() { defaultPrevented = true; that.originalEvent && that.originalEvent.preventDefault() // ERROR }

                                1 Solution

                                Creation Date Importance Sort by

                                looks like this old dashboard libraries causing the issue. all good. thanks

                                "scripts": [
                                              "node_modules/jszip/dist/jszip.min.js",
                                              "src/assets/scripts/dx.dashboard-control.third-party.min.js",
                                              "src/assets/scripts/dx.dashboard-control.bundle.min.js"
                                            ]

                                • Romeo (DevExpress Support) 10.22.2019

                                  I'm happy to hear that you have resolved the issue. Do not hesitate to contact us if you have further questions.

                                  Regards,
                                  Romeo