Current filter:
                                You should refresh the page.
                                  • We installed 19.1.5 of the Report Server a few days ago on our test system and we are no longer able to run reports.  When we try to run them, we either get a red error at the bottom of the screen that says "Server Error" or no error at all.  I either case, it basically just displays a blank report viewer.

                                    If I try to create a new report with the report designer, and try to preview a report I get the same Server Error message.

                                    I've tried reports with and without parameters.

                                    I've attached the web.log which should have more details of the error.  What I see is that it is attempting to access resources on localhost absent the port.  We have the report server on the default port of 83.  For example, the log indicates it's attempting to access https://localhost/worker/Job/Run.  I would think it is supposed to be https://localhost:83/worker/Job/Run.

                                • Andrey (DevExpress Support) 08.08.2019

                                  Please provide us with a screenshot of the Report and Dashboard Server web site bindings from the IIS Management Console and with a screenshot illustrating General Settings of the Report and Dashboard Server.

                                • Larry Pope 08.08.2019

                                  Attached are screenshots of the bindings and general settings.

                                  I added the https binding because I was working with Dmitry Tokmachev on getting the React components working from Oliver Sturm's post in July .

                                  If I change it to, reporting is now working.  It's not critical for us to have the React components working, so the immediate issue is fixed.

                                  Give me a couple of days to get back to the React component project I have to see if that is broken now with the change I just made.

                                1 Solution

                                Creation Date Importance Sort by

                                Hello Larry,
                                Thank you for the screenshots. If you switch the Report and Dashboard Server to the HTTPS protocol, so the address of the Report and Dashboard Server's web site is, it is also necessary to add the following binding for the web site: https://localhost:443. Such a binding is required by the server's Worker process. In the scenario when you are using the binding everything works fine because the web sit has the http://*/:83 binding. Please try the suggested solution and let me know your result.