Current filter:
                                You should refresh the page.
                                  • [DevExpress Support Team: CLONED FROM T745094: VS 2019 reports coderush is slowing typing]
                                    It looked like the problem had gone away, but I've had it a number of times in my current editing session. Caught the last one with the performance monitoring switched on, and will include the logs. Whilst I'm at it, I've recorded something else strange. Not sure whether this is a coderush issue or a VS2019 issue, as I installed VS2019 v16.1 and a coderush update at around the same time. Since doing so I've noticed quite a lot of times when intellisense isn't picking up completions that it should be. As it happened, this manifested itself whilst I was recording the performance data, so I've recorded it for you to take a look at. Here's a link to the screencast. I'm trying to type the class private variable "_legKey", but it won't recognise it, despite it working fine a few seconds earlier on the other half of the And. Also once it incorrectly selects "Key" as a completion, and I delete it, it starts working again, and correctly offers up _legKey. I've spotted this numerous times over the last week or so, but not had the chance to catch it until now

                                    Forgot to add, this had been happening for almost every field in the select part of the Linq statement at the top of the screenshot, which is why I was trying to retype that statement to reproduce the error. I can't say for sure if this is only happening withing Linq statements, but I feel it might be

                                Show all comments
                                • Alex Eg (DevExpress) 06.07.2019

                                  Hi Kevin,
                                  I couldn't reproduce the issue. As I can see from your screencast, there are red squiggles in your LINQ statement, so the issue can be related to the incomplete parsing. Can you please try to perform the same actions with disabled CodeRush and see if the issue persists? Can you provide us with a sample project and specific steps to reproduce the issue so that we can research the situation on our machines? Thanks in advance!
                                    

                                • Kevin O'Donovan 08.15.2019

                                  Just noticed that this has started again in the last few days. It looks like a coderush update was applied as well, as I had a request to let ngen run when I started visual studio. My current version is 19.1.7. I've attached a screenshot showing the issue. The variable "prefix" is declared a few lines earlier in the same scope block, but isn't being recognised by intellisense. Looking at the screenshot, it appears to be ignoring the first letter and returning matches containing "ref"??

                                • Kevin O'Donovan 08.15.2019

                                  I've also noticed this happening a lot in Catch blocks. For example, "Catch ex as Exception" would fail to recognise "ex" in the first (and only) line in the handler. Another one I can specifically remember was using a variable named "loc" which would bring up Oct as match, which fits with the first character being ignored.

                                • Kevin O'Donovan 08.15.2019

                                  And another example - in this screencast I'm typing "_data" but its ignoring the underscore and matching to the Data namespace instead

                                • Kevin O'Donovan 08.15.2019

                                  Just checked - the correct completion is available in the intellisense list at the bottom, its just not being noticed as the most exact match

                                • Alex Eg (DevExpress) 08.16.2019

                                  Hi Kevin,
                                  Thank you for the provided information. I reproduced the issue and it seems that CodeRush somehow affects IntelliSense even when IntelliRush and Naming Assistant features are disabled. Please give us some time to research the situation.

                                • Kevin O'Donovan 08.16.2019

                                  No problem. Happy to see it nailed down

                                1 Solution

                                Creation Date Importance Sort by

                                Hi Kevin,
                                We researched the issue and found a solution - the issue isn't reproducible on our machines anymore. Please try this build and inform us about your results:
                                http://downloads.devexpress.com/Share/IDE/190820/DevExpress.CodeRush-19.1.7.19232.exe

                                • Kevin O'Donovan 08.22.2019

                                  Sorry, only just spotted this - never got a notification there was a new post in here?!? Anyway, downloaded it and tried it out, and initial impressions are good. Not been able to reproduce the issue since. I'll give it the rest of the afternoon and if it's still clear I'll mark this as the answer

                                  Thanks for the quick response folks!

                                  Kev

                                • Alex Eg (DevExpress) 08.22.2019

                                  Hi Kevin,
                                  We are looking forward to hearing from you!

                                • Kevin O'Donovan 08.22.2019

                                  Seems to be sorted, thanks - was driving me mad!

                                • Alex Eg (DevExpress) 08.23.2019

                                  Thank you for the update! I'm happy to hear that the issue is resolved.