Current filter:
                                You should refresh the page.
                                  • Hello there,

                                    I am having problems editing powershell files in visual studio. (everything else and every other filetype seems to work fine)...The text that is meant to be comments show in large green text that make it very hard to read. I have no idea how it got this way. Just seemed to start happening one day....

                                    Attached is an image of what my powershell comments look like.

                                    Could anyone suggest how I can fix this? or how I can reset my code editing format to defaults?

                                    Thank you
                                    John

                                Show all comments
                                • Alex Eg (DevExpress) 10.16.2018

                                  Hi John,
                                  It seems that the painting is caused by the Rich Comments feature. You can disable it on the CodeRush toolbar:
                                  https://www.screencast.com/t/XbjnY0dB
                                  If you want to keep the Rich Comments feature, then you can disable the 'Change comment font size and color' options(CodeRush\Options\Editor\All Languages\Rich Comments):
                                  https://www.screencast.com/t/wb3zl2wFD
                                  Please inform us about your results!

                                • John Sheppard 10.17.2018

                                  Thanks Alex.

                                  This indeed solved the problem. I must have accidentally click the toolbar icon. Then not being familiar with the feature...didnt notice...

                                  Really appreciate your help! Could have been looking for days for that one :)

                                  John

                                • Alex Eg (DevExpress) 10.17.2018

                                  Hi John,
                                  The 'Rich Comments' feature is enabled by default. It's great to hear that our solution was helpful! Could you please send us one of your powershell files where unexpected behavior was reproduced so we can try to improve our product?

                                • John Sheppard 10.18.2018

                                  Hi Alex, It is unfortunately, every powershell script that I have...it is not unique to just one...

                                • John Sheppard 10.18.2018

                                  I forgot to mention I took a quick video if that helps. But yeah, same thing happens on all the powershell files I have tried...

                                • Alex Eg (DevExpress) 10.18.2018

                                  John,
                                  Thank you for the video. We will research the issue and see if we can improve our logic. Thank you for your patience!

                                1 Solution

                                Creation Date Importance Sort by
                                • Ondřej Linhart 11.26.2018

                                  Problem fixed in v18.2.3.

                                • Eugene R (DevExpress) 11.26.2018

                                  Hi Ondřej,

                                  Thank you for the update.