Current filter:
                                You should refresh the page.
                                  • Hi,

                                    As soon as I installed the latest version  of CodeRush Ultimate in my development PC, I rushed to start adding images to my source code to make some hard to understand methods and calculations clearer. This is a much needed and surprising feature.

                                    I am trying to paste an image in the C# code in a form, as shown in your site (https://community.devexpress.com/blogs/markmiller/archive/2018/09/11/holy-grail-embedded-images-inside-source-code.aspx), but, after copying the image to the clipboard, VS does not show the Past Image option, as shown in you posting, inside a commented line. Not even the Paste menu is enabled.

                                    Am I missing something here?

                                    I run VS 2017 Enterprise 15.8.4 in Administrator mode.

                                    Thanks for your support.

                                    Eduardo Quintana

                                Show all comments
                                • Alex Miller 09.19.2018

                                  Same here. I do not see the option. Admin mode... CodeRush 18.1.11 on VS 15.8.4. 

                                • Olaf Kober 09.20.2018

                                  I experience the same. v18.1.11 with VS 15.8.4.

                                • Dmitry O (DevExpress) 09.20.2018

                                  Hi,
                                  Thank you for your inquiries.
                                  Guys, could please check that you have the "Rich Comments" feature enabled on your side? For this, check the CodeRush->Options->Editor->All Languages->Rich Comments->Enabled checkbox.
                                  Now, the "Rich Comments" feature has one limitation - after CodeRush is updated to v18.1.11 and your Visual Studio restarts, it's necessary to restart Visual Studio one more time, and then the "Rich Comments" feature should work properly.
                                  Could you try these steps and provide me with your results in the context of the current ticket?

                                  Note: we are doing our best to fix the limitation with Visual Studio restart and will fix shortly.

                                • Buk Hix 09.20.2018

                                  I applied these steps and it did not make any difference.

                                • Eduardo Quintana 09.20.2018

                                  It worked for me... see attached image.

                                  Eduardo Quintana

                                • Buk Hix 09.20.2018

                                  Thank you for posting that. I missed the instruction that I had to start out with comment slashes. Seeing your example set me straight on that and now it works.

                                • Dmitry O (DevExpress) 09.20.2018

                                  Guys, thank you for your answers. I am happy to hear that "Rich Comments" now works on your side.
                                  We have decided to enable the "Rich Comment" feature by default and fixed the "Rich Comment" limitation with Visual Studio restart.
                                  CodeRush will have an update with fixes of problems in the near future.

                                1 Solution

                                Creation Date Importance Sort by

                                Fixed: