Current filter:
                                You should refresh the page.
                                Show all comments
                                • Alex X (DevExpress) 01.30.2017

                                  Hi Alexei,

                                  Thank you for letting us know about this problem.
                                  I have tried to reproduce it locally but failed. Here is a screencast of my steps: https://www.screencast.com/t/9vXwjRsbyuKr

                                  To help us to determine the cause of this problem, could you provide us with the following information:

                                  1. Clarify if tests are running in Visual Studio built-in test runner.  Open the Test Explorer window via the "Tests | Windows | Test Explorer" menu. Paste the following text "Microsoft.CodeAnalysis.CSharp.UnitTests.CodeGen.PropertyTests" in the filter field atop of this window. The "ExpressionBodedProperty" test should be filtered. Right click on this test and select the "Run Selected Tests" item from the context menu. Tell us if the test runs normally on your machine.
                                  '

                                  2. Open the command line (cmd.exe). Navigate to the repository root directory. Run the following command:

                                  [C#]
                                  dir .\Binaries\Debug\UnitTests\CSharpCompilerEmitTest\ > files.txt

                                  The "files.txt" file should be created in the repository root folder. Share this file with us.

                                  3. Record a screencast illustrating the problem in action. This may help shade some light on the nature of this problem.
                                  To capture a screencast you may use, for instance, the free Jing tool from TechSmith.

                                  I look forward to hearing from you!

                                • Alexei Marine 02.02.2017

                                  Hello Alex.

                                  Thank you for the response. It looks like the problem is not related to the CodeRush. I cannot run the tests through the Test Explorer either, all "Run" commands are disabled and the progress bar is throbbing even though the tests have been discovered. This persists even after the reinstallation of Windows and VS. I think I'll have to investigate further myself. Thank you for your assistance.

                                • Alex X (DevExpress) 02.03.2017

                                  Hi Alexei,
                                  Thank you for the update.
                                  I'm concerned to hear that you are experiencing a problem with running tests. When I was trying to reproduce this problem, I noticed that the Visual Studio test explorer doesn't allow running tests before it has not found all tests within a solution. But, the Roslyn project is quite large so it takes about 30 min before I can run any test on my machine via Test Explorer.
                                  Could you provide us with CodeRush log files? They may shade some light on the cause of the problem. You can find them at the following location: %LocalAppData%\CodeRush\Logs.

                                • Alexei Marine 02.03.2017

                                  Hi.

                                  I have an older branch of Roslyn where the projects don't include xUnit VS integration, so the tests aren't available in Test Explorer, but Test Runner can run any tests without any extraordinary delay.

                                  Anyway, I've attached the latest log. All other TestRunner logs look like that.

                                • Alexei Marine 02.03.2017

                                  Bingo! I've replaced the Newtonsoft.Json.dll in the rmyfztmi.fjf extension folder with version 8.0.3, and everything started working again. The VS integration bundled with Roslyn was a red herring.

                                • Alexei Marine 02.03.2017

                                  Alas, that wasn't that easy. This only works if you load VS and the solution first, then swap the dll and start running tests.

                                • Alex X (DevExpress) 02.06.2017

                                  Hi Alexei,

                                  Thank you for the update and providing the log file. It has been very helpful.
                                  I have managed to reproduce the problem with the Newtonsoft.Json.dll file locally. We are researching the cause of this issue. You'll be notified when we prepare a fix.

                                • Ondřej Linhart 04.27.2017

                                  This started happening to me too.

                                • Alex X (DevExpress) 04.27.2017

                                  Hi Ondřej,

                                  Could you clarify if you have experienced trouble with running xunit tests within the Roslyn solution? Also, please provide us with CodeRush log files. You can find them at the following location: %LocalAppData%\CodeRush\Logs.

                                1 Solution

                                Creation Date Importance Sort by

                                Fixed: