Current filter:
                                You should refresh the page.
                                Show all comments
                                • Pavel A (DevExpress) 09.29.2016

                                  Hello Robert,

                                  It seems something went wrong with your installation.

                                  Could you please execute the following steps and let us know your results?

                                  1. Close all Visual Studio instances.
                                  2. Go to the %LocalAppData%\Microsoft\VisualStudio\14.0 folder and remove the ComponentModelCache subfolder.
                                  3. Go to the %LocalAppData%\Microsoft\VisualStudio\14.0\Extensions folder and remove all subfolders that contain the DevExpress.CodeRush.Package.pkgdef file.
                                  4. Remove all .cache files from the %LocalAppData%\Microsoft\VisualStudio\14.0\Extensions folder.
                                  All these operations are safe and will not break Visual Studio.

                                  After this, please install the build with the hotfix and try to reproduce the issue.

                                  If it does not help, please provide with us the following information:
                                   - your CodeRush settings. They are located here: %AppData%\CodeRush\Settings
                                   - a code sample where the issue is reproducible.

                                  We look forward to your response.

                                • Robert Leahey 09.29.2016

                                  Hello Pavel,

                                  The steps you gave me did not solve the issue. I'm including my zipped settings folder.
                                  There's not really Code to Reproduce because the error occurs any time I select Organize Members.

                                  Thanks.

                                • Pavel A (DevExpress) 09.30.2016

                                  Hello Robert,

                                  Thank you for providing your settings.

                                  I managed to reproduce this issue with your settings.

                                  We will research it and let you know as soon as we have any results. 

                                • Robert Leahey 10.07.2016

                                  Hi Pavel,

                                  I'm still seeing the CodeCleanUpProvider fail when I attempt to use Organize Members. Though since installing the hotfix it now fails intermittently rather all the time. I have a .cs file with which I can regularly demonstrate the issue, and I'm including it here.

                                  With this file as it is currently, Organize Members will fail for me. However, if I remove the "temp" #region from around the indexer property, Organize Members seems to work correctly.

                                • Robert Leahey 10.07.2016

                                  On further examination, using this same example unit, if I
                                  - remove the "temp" region and successfully apply Organize Members,
                                  - then rename the generated "fields" region to "temp"
                                  - reapply Organize Members
                                  The CodeCleanUpProvider fails again.

                                  Unrelated: applying Organize Members multiple times adds a blank line between a #region head and the next line of code each time it is applied. 

                                • Pavel A (DevExpress) 10.07.2016

                                  Hello Robert,

                                  Thank you for your research and providing the code sample.

                                  I have reproduced the issue with your settings.

                                  Once we fix this issue, you will be automatically notified.

                                  Regarding the issue with adding blank lines each time Organize members is applied, I have created a new ticket: Organize Members adds a blank line between a #region head and the next line of code each time it is applied and will answer you there.

                                • Robert Leahey 10.29.2016

                                  Hi Pavel,

                                  I got sort of lost in the mix of branching issues, multiple instances of this CodeCleanUpProvider problem, and hotfixes for other tickets. What is the current status of this? Do you have a hotfix for the 2nd instance of the issue or should I just wait for the next regular release?

                                • Pavel A (DevExpress) 10.31.2016

                                  Hi Robert,

                                  We have fixed all the issues you reported to us.
                                  The fixes will be available in the next release 16.1.8 that is expected these days.

                                1 Solution

                                Creation Date Importance Sort by

                                Fixed: