Current filter:
                                You should refresh the page.
                                  • The Place System references first option does not work correctly

                                    [VB.NET]
                                    Imports System.Data Imports ConsoleAppTest.MyTestNamespace Imports System.Windows.Forms Public Class Class1 Public Sub RunTest() Dim cls As New Class2 cls.Test() End Sub End Class Namespace MyTestNamespace Public Class Class2 Public Sub Test() Dim table As New DataTable Dim ctl As New Button End Sub End Class End Namespace

                                    Code Cleanup for the above folder sorts the namespace references as follows.  They are sorted alphabetically but the system references are not first.

                                    [VB.NET]
                                    Imports ConsoleAppTest.MyTestNamespace Imports System.Data Imports System.Windows.Forms
                                • Alex Eg (DevExpress) 08.29.2016

                                  Hi John,
                                  I have reproduced the issue, and we are working on it. I will notify you once we get any results.

                                1 Solution

                                Creation Date Importance Sort by

                                Fixed:

                                • John Szentes 09.09.2016

                                  I installed the hotfix (v16.1.6.16251) and it did not work.  In fact there was no change at all.  The namespaces are sorted alphabetically and the Place system references first option continues to be ignored.

                                • George K (DevExpress) 09.09.2016

                                  Hi John,
                                  I apologize that this fix does not work, I see the problem with the options page.
                                  So as a workaround, I suggest you close Visual Studio and copy the attached file to this - %AppData%\CodeRush\Settings\Private\  folder. It should help you.
                                  When we resolve this issue, we will inform you.

                                • John Szentes 09.09.2016

                                  That works much better.  Thanks.

                                  BTW - you might want to update your attached xml file.  It is not valid XML.  You left the closing bracket in the first Options tag

                                  [XAML]
                                  <Options Language="Visual Basic" />

                                  It does work with the fix

                                • George K (DevExpress) 09.09.2016

                                  Hi John,
                                  Thanks for this information. I updated this file.

                                • Alex Eg (DevExpress) 09.14.2016

                                  Hi John,
                                  We have corrected this issue and a build with the fix will be released soon.