Current filter:
                                You should refresh the page.
                                  • When running the refactor of Make Explicit, CR adds an import to the namespace containing the type I am using. Is there a way to have CR just add the correct type with it's namespace instead of putting the namespace in the imports? This has caused me a few conflicts when the new imported namespace contained classes with similar names to those already imported in other namespaces

                                • Andrew A (DevExpress) 06.20.2019

                                  Hi Dan,

                                  I have reproduced this issue locally. It looks like a bug, because for the C# code, Make Explicit works correctly and inserts the full type name. We will research the possibility of resolving this issue for Visual Basic and inform you about our progress.
                                  As a workaround, I suggest that you turn on the option to always declare a fully qualified type name.
                                  Note: this option is used for all CodeRush features that declare the type name.

                                1 Solution

                                Creation Date Importance Sort by

                                Fixed: