Current filter:
                                You should refresh the page.
                                  • Hello,
                                    When trying to bootstrap a demo with angular 7 and adding devextreme, have the following error with running command:

                                    [C#]
                                    ng add devextreme-angular@18.2

                                    Error is as follow

                                    [C#]
                                    Installing packages for tooling via npm. npm WARN ajv-keywords@3.4.0 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself. npm WARN bootstrap@4.2.1 requires a peer of jquery@1.9.1 - 3 but none is installed. You must install peer dependencies yourself. npm WARN bootstrap@4.2.1 requires a peer of popper.js@^1.14.6 but none is installed. You must install peer dependencies yourself. npm WARN devextreme-angular@18.2.5 requires a peer of devextreme@~18.2.5 but none is installed. You must install peer dependencies yourself. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.7 (node_modules\webpack-dev-server\node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.7: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.7 (node_modules\watchpack\node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.7: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.7 (node_modules\karma\node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.7: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.3 (node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) + devextreme-angular@18.2.5 added 2 packages in 28.371s Installed packages for tooling via npm.

                                    Do yu have any idea ?I attached my package.json for you to check my config

                                • Sylvain GIRARD 02.12.2019

                                  Also when running a new test project

                                  > npx.cmd ng new test --style=scss --routing=false --skip-install=true --skip-tests=true

                                  I have the error as follow
                                  npx: installed 1 in 2.784s
                                  Path must be a string. Received undefined
                                  F:\KmProdWeb\KmCore\KmCore\ClientApp\node_modules@angular\cli\bin\ng
                                  The new command requires to be run outside of a project, but a project definition was found at "F:\KmProdWeb\KmCore\KmCore\ClientApp\angular.json".
                                  (node:21744) UnhandledPromiseRejectionWarning: 1
                                  (node:21744) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
                                  (node:21744) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
                                  PS F:\KmProdWeb\KmCore\KmCore\ClientApp\npx>

                                • Sylvain GIRARD 02.12.2019

                                  I fixed it on my side by creating a new project with your cli and replacing manually the files but that's not the expected behaviour

                                • Artem (DevExpress Support) 02.12.2019

                                  Hi,

                                  Thank you for the update.  The "npm WARN" lines indicate that some packages don't have required dependencies. I see that there is no "devextreme" package in package.json. Do you mean that "ng add devextreme-angular@18.2" didn't install it? If so, make sure that you installed our CLI first (see Installation)

                                  As for the 'Unhandled promise rejection.' it looks like it occurs because " ng new" was called inside the existing project:

                                  [XML]
                                  Path must be a string. Received undefined F:\KmProdWeb\KmCore\KmCore\ClientApp\node_modules\@angular\cli\bin\ng The new command requires to be run outside of a project, but a project definition was found at "F:\KmProdWeb\KmCore\KmCore\ClientApp\angular.json".

                                  In any case, feel free to attach a test example where the issue occurs, so we can test the same steps in action to see what goes wrong.

                                1 Solution

                                Creation Date Importance Sort by

                                Hi guys, thanks for the answer
                                Do you mean that "ng add devextreme-angular@18.2" didn't install it? If so, make sure that you installed our CLI first (see Installation)
                                CLI

                                My answer: The CLI was installed but i wanted to add the template to an existing project like your wiki said it's possible .. Anyway i got it working on my side. But i faced many other issues see bellow.

                                I also submit few issue on your github repository, do you prefer me to create new tickets here ?
                                https://github.com/DevExpress/devextreme-angular-template/issues/106
                                https://github.com/DevExpress/devextreme-angular-template/issues/107

                                • Nikolai (DevExpress Support) 02.13.2019

                                  Hi,

                                  We are happy to hear that the issue has been resolved.

                                  As for GitHub issues, we guarantee a response within 24 hours only for tickets posted in the Support Center. Issues posted on GitHub may be processed longer. You do not need to duplicate those issues in the Support Center. We will reply to you on GitHub.