Current filter:
                                You should refresh the page.
                                  • While rich comments are neat in source code, I kinda don't want them in (XML) config files - ie. files with the extension *.xml and *.config

                                    One of my config files contains a set of connection strings, and all but one are commented out; so if I have to switch between them i can just comment one and uncomment the other.
                                    With rich comments however, it looks like this:

                                    The problem here is that both the word "connection_string" and the database name "DB_Test", "DB_Stage" etc. contain an underscore - not to make it pretty and underline, but because it (somewhat) makes sense for naming.
                                    Similarly, this also happens (a lot more frequently) in Oracle connection strings since they like using underscores for combined words.

                                    For that, I'd like to propose a feature that lets me enable (or disable) this for specific file types (or extensions).

                                    Also, while writing this (and replacing some of the strings in there), it happened multiple times that clicking into the line did not revert the rich formatting. Even after editing the line, the underlining persisted and moved the caret off-by-one due to the hidden underscore.
                                    But this should probably in a ticket of its own.

                                • Emanuel Wlaschitz 09.26.2018

                                  Ugh, it ate my pasted screenshot again. Here it is:

                                • Alex Z (DevExpress) 09.26.2018

                                  Emanuel,

                                  We will consider implementing additional options for rich comment configuration for future versions.
                                  I have also tried to reproduce the issue with rich comments painting not being removed.
                                  Please see the following screencast: https://www.screencast.com/t/OvmZOuvyG

                                • Emanuel Wlaschitz 09.26.2018

                                  I don't have Flash player installed, so I cannot view that screen cast.

                                  But you could try the following steps:

                                  1. Copy one of those connection strings (which are NOT commented out) a couple of times so you have at least 3 lines.
                                  2. Comment out the 2nd one by moving the cursor into the line and invoking the Visual Studio command "Comment Selection" (Ctrl+E, C or similar, depending on key bindings). Do NOT explicitly select the element, Visual Studio will take care of that.
                                  3. Verify that this now commented out 2nd line behaves correctly.
                                  4. Comment out the 3rd line by doing the same as in step 2.
                                  5. Verify that the 3rd line behaves correctly, but the 2nd line is now broken.

                                  That reproduces nicely for me, every time.

                                • Alex Z (DevExpress) 09.26.2018

                                  Emanuel,

                                  Thank you for the steps. I have reproduced this issue. I have created a new ticket on your behalf: Rich Comment painting is not removed in certain cases when the caret is placed into a comment

                                0 Solutions

                                Creation Date Importance Sort by