Current filter:
                                You should refresh the page.
                                  • I upgrade one of my project to 18.1.3 and when try to run it in debug mode i get exception during update:

                                    FormatException
                                    String was not recognized as a valid DateTime.
                                       at System.DateTimeParse.Parse(String s, DateTimeFormatInfo dtfi, DateTimeStyles styles)
                                       at System.Convert.ToDateTime(String value, IFormatProvider provider)
                                       at System.String.System.IConvertible.ToDateTime(IFormatProvider provider)
                                       at System.Convert.ChangeType(Object value, Type conversionType, IFormatProvider provider)
                                       at DevExpress.Xpo.DB.ConnectionProviderSql.ReformatReadValue(Object value, ReformatReadValueArgs args)
                                       at DevExpress.Xpo.DB.MSSqlConnectionProvider.GetColumns(DBTable table)
                                       at DevExpress.Xpo.DB.MSSqlConnectionProvider.GetTableSchema(DBTable table, Boolean checkIndexes, Boolean checkForeignKeys)
                                       at DevExpress.Xpo.DB.ConnectionProviderSql.ProcessUpdateSchema(Boolean skipIfFirstTableNotExists, DBTable[] tables)
                                       at DevExpress.Xpo.DB.DataStoreSerializedBase.UpdateSchema(Boolean dontCreateIfFirstTableNotExist, DBTable[] tables)
                                       at DevExpress.Xpo.DB.ConnectionProviderSql.UpdateSchema(Boolean dontCreateIfFirstTableNotExist, DBTable[] tables)
                                       at DevExpress.Xpo.SimpleDataLayer.<>c__DisplayClass4.<UpdateSchema>b__3()
                                       at DevExpress.Xpo.SimpleDataLayer.ReentrancyAndThreadSafetyChecked[T](Func`1 action)
                                       at DevExpress.Xpo.SimpleDataLayer.UpdateSchema(Boolean dontCreate, XPClassInfo[] types)
                                       at DevExpress.Xpo.SimpleObjectLayer.UpdateSchema(Boolean dontCreateIfFirstTableNotExist, XPClassInfo[] types)
                                       at DevExpress.Xpo.Session.UpdateSchema(Boolean dontCreateIfFirstTableNotExist, XPClassInfo[] types)
                                       at DevExpress.Xpo.Session.UpdateSchema(XPClassInfo[] types)
                                       at DevExpress.ExpressApp.Xpo.XPObjectSpaceProvider.DevExpress.ExpressApp.IObjectSpaceProvider.UpdateSchema()
                                       at DevExpress.ExpressApp.Updating.DatabaseUpdaterBase.UpdateCore(IObjectSpace updatingObjectSpace, IList`1 versionInfoList)
                                       at DevExpress.ExpressApp.Updating.DatabaseUpdater.Update()

                                    how to locate what exactly is wrong ?

                                    UPDATE:
                                    Type:       FormatException
                                       Message:   Input string was not in the correct format
                                       Data:       0 entries
                                       Stack trace:

                                       en System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
                                       en System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
                                       en System.String.System.IConvertible.ToInt32(IFormatProvider provider)
                                       en System.Convert.ChangeType(Object value, Type conversionType, IFormatProvider provider)
                                       en DevExpress.Xpo.DB.ConnectionProviderSql.ReformatReadValue(Object value, ReformatReadValueArgs args)
                                       en DevExpress.Xpo.DB.MSSqlConnectionProvider.GetColumns(DBTable table)
                                       en DevExpress.Xpo.DB.MSSqlConnectionProvider.GetTableSchema(DBTable table, Boolean checkIndexes, Boolean checkForeignKeys)
                                       en DevExpress.Xpo.DB.ConnectionProviderSql.ProcessUpdateSchema(Boolean skipIfFirstTableNotExists, DBTable[] tables)
                                       en DevExpress.Xpo.DB.DataStoreSerializedBase.UpdateSchema(Boolean dontCreateIfFirstTableNotExist, DBTable[] tables)
                                       en DevExpress.Xpo.DB.ConnectionProviderSql.UpdateSchema(Boolean dontCreateIfFirstTableNotExist, DBTable[] tables)
                                       en DevExpress.Xpo.SimpleDataLayer.<>c__DisplayClass4.<UpdateSchema>b__3()
                                       en DevExpress.Xpo.SimpleDataLayer.ReentrancyAndThreadSafetyChecked[T](Func`1 action)
                                       en DevExpress.Xpo.SimpleDataLayer.UpdateSchema(Boolean dontCreate, XPClassInfo[] types)
                                       en DevExpress.ExpressApp.Xpo.XPObjectSpaceProvider.DevExpress.ExpressApp.IObjectSpaceProvider.UpdateSchema()
                                       en DevExpress.ExpressApp.Updating.DatabaseUpdaterBase.UpdateCore(IObjectSpace updatingObjectSpace, IList`1 versionInfoList)
                                       en DevExpress.ExpressApp.Updating.DatabaseUpdater.Update()
                                       InnerException is null

                                • Uriah (DevExpress Support) 06.04.2018

                                  Hello Debeściak,

                                  Thank you for contacting us. We found that this error occurs when a Date column in the database has the DEFAULT constraint providing an empty string as a default value.

                                  Our developers are working on this issue to fix it in the next version. In the meantime, you can resolve this error by removing the corresponding constraint. Please try this solution and let us know if it helps.

                                • Debeściak 06.04.2018

                                  there a lot of tables in database. is there any idea how to locate which table make this issue ?

                                • Customer6896 06.04.2018

                                  I am having the same issue. Turning on the log (option 4) and you could find out what table having that issue.

                                • Debeściak 06.04.2018

                                  could you explain how to turn on option 4 in log ?

                                • Customer6896 06.04.2018

                                  Put this one into App.config

                                  [C#]
                                  <system.diagnostics> <trace autoflush="true" indentsize="4"> <listeners> <add name="LogFileTraceListener" type="System.Diagnostics.TextWriterTraceListener" initializeData="trace.log" /> <remove name="Default" /> </listeners> </trace> <switches> <add name="eXpressAppFramework" value="4" /> <add name="XPO" value="4" /> </switches> </system.diagnostics>

                                1 Solution

                                Creation Date Importance Sort by

                                Fixed: