Current filter:
                                You should refresh the page.
                                  • Type the following code

                                    [C#]
                                    #if // le

                                    then press space. "le" will expand into LanguageElement and add the relevant using. It should not be expanded in comments.

                                • Alex Z (DevExpress) 08.31.2017

                                  Dominic,

                                  Thank you for bringing our attention to this issue. I have reproduced it and we are working on fixing it.

                                1 Solution

                                Creation Date Importance Sort by

                                Fixed:

                                • Dominic C 04.09.2018

                                  THis has been broken again (using 17.2.7.18081)

                                • Alex Z (DevExpress) 04.10.2018

                                  Dominic,

                                  Please check to see if the "le" template has the following context specified: !([InAnyComment] || [InString]).
                                  Follow these steps to get to the Templates options page:

                                  1. From the Visual Studio menu, select "CodeRush\Options..." .
                                  2. In the tree view on the left, navigate to this folder:
                                              Editor\All Languages
                                  3. Select the "Templates" options page.
                                  4. Search for the "DevEx\CodeRush\le" template and check its context string.

                                  If the context is different, try to change it to !([InAnyComment] || [InString]) and click Ok to close the options dialog.
                                  Please refer to the following screenshot for more details.