Current filter:
                                You should refresh the page.
                                  • [DevExpress Support Team: CLONED FROM T462705: Unable to debug tests using CodeRush for Roslyn 16.2.3]
                                    Same here with VS2015 Community/Update3 and XUnit 2.1.

                                    I cannot debug and execute " Theory" based tests while clicking on the test symbol of the test method.
                                    If i use the test symbol on the whole class, it's possible to run all tests including "Theory" based tests.

                                • Alex B.G. (DevExpress) 12.16.2016

                                  Hi Silvio,
                                  I have reproduced the issue. Also, I have noticed that it appears only if I try to start debugging the test from the test icon. If I run debugging from the Test Runner window, or from the test class Icon all works properly (see the attached screencast). Please use these ways as temporary workaround. Once we fix it, we will update this thread.

                                • Silvio Boehme 12.22.2016

                                  Hi!

                                  I have applied the hotfix 16.2.3.16356, and everything is fine now.
                                  I can run all test.

                                • Alex B.G. (DevExpress) 12.22.2016

                                  Silvio,
                                  Thank you for letting us know. If you have any further questions feel free to contact us.

                                1 Solution

                                Creation Date Importance Sort by

                                Fixed:

                                • Kyle Hatcher 1 01.06.2017

                                  This is still partially broken in v16.2.3.16356

                                  Close the solution with the tests.
                                  Open the solution.
                                  Build.
                                  Go to the Test Runner screen.
                                  All tests should show the blue "without state" icon.
                                  Right click the specific parameterized test and choose run.
                                  The first time, this will fail with the error message posted by https://www.devexpress.com/Support/Center/Question/Details/T463747
                                  Right click, Run again, now it works.

                                  Additionally; the Hotfix link you posted shows v16.2.4, but the version it actually downloads is 16.2.3

                                • Alex B.G. (DevExpress) 01.09.2017

                                  Hi Kyle,

                                  I have tried to reproduce the issue using steps you described in my test project and XUnit 2.1, but didn't manage. All works properly on my side (see the attached screencast). Perhaps the issue is related to specific conditions on your side. To process this issue in the most efficient way, I've created a separate ticket on your behalf:
                                  Right click the specific parameterized test and choose run will fail with the error message
                                  It has been placed in our processing queue and will be answered shortly.

                                  As for the HotFix link and version, it all is correct. The issue is fixed in version 16.2.4, which will be our next official update. To ensure that you aren't waiting for the official update, we have provided the interim build 16.2.3.16356 containing all the changes that were made after the release of 16.2.3 including the bug fix.