Current filter:
                                You should refresh the page.
                                  • [DevExpress Support Team: CLONED FROM T451150: VS2017 RC Support - Test Runner doesn't run unit tests created with Visual Studio]
                                    It's still not working for me. The Output window shows "Test started...", but nothing happens. The tests run fine with the Visual Studio test tools.

                                    Microsoft Visual Studio Community 2017 RC
                                    Version 15.0.26009.0 D15REL

                                    CodeRush for Roslyn   16.2.3.0
                                    DevExpress CodeRush for Roslyn package.

                                    Reference set to "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\PublicAssemblies\Microsoft.VisualStudio.QualityTools.UnitTestFramework.dll"

                                Show all comments
                                • Alex B.G. (DevExpress) 12.15.2016

                                  Hi Olivier,

                                  Please give us some time to reproduce the issue.
                                  It would be very helpful if you can provide us with a sample project in which the issue is reproducible.

                                  Also please provide us with Test Runner logs. You can obtain it by the following path:
                                  %LocalAppData%\CodeRush\Logs

                                  Please zip this folder and attach the obtained archive to your next message.

                                • Olivier Jacot-Descombes 12.15.2016

                                  DropBox links for accessible to support@devexpress.com and SupportCenter@devexpress.com

                                  Solution: CySoft.Wff
                                  Logs: logs

                                • Alex B.G. (DevExpress) 12.16.2016

                                  Hi Olivier,

                                  Thank you for the provided info. I found a few messages about System.ArgumentNullException in your logs. It seems to be the cause of the issue, and it is related to the fact that probably you have no Visual Studio 2015 installed. As soon as we fix this exception, we will update this thread.

                                • Olivier Jacot-Descombes 12.16.2016

                                  I have in fact no Visual Studio 2015 installed.

                                • Alex B.G. (DevExpress) 12.16.2016

                                  Olivier, thank you for replying.

                                  We will try to fix this issue and provide you a build, so you can check whether the issue disappears.

                                • Alex B.G. (DevExpress) 12.21.2016

                                  Hi Olivier,

                                  Please try the following build:
                                  http://downloads.devexpress.com/Share/IDE/161221/DevExpress.CodeRush.Roslyn-16.2.3.16356.vsix

                                  It contains the necessary changes that should fix the issue. Let us know how it works on your side.

                                • Olivier Jacot-Descombes 12.21.2016

                                  Fantastic! The Test Runner works now.
                                  Thank you very much.

                                  (Note: This might be interesting for others. The provided vsix did not relpace the previous version of CodeRush automatically. I had to uninstall the previous version before installing this new vsix. Maybe a bug in VS 2017 RC.)

                                • Pavel A (DevExpress) 12.21.2016

                                  Hello Olivier,

                                  Since the issue is resolved, can I ask you for permission to mark this ticket public?
                                  Then, we will be able to include it to the list of resolved issues when we publish the next release build.

                                • Olivier Jacot-Descombes 12.21.2016

                                  Hello Pavel,

                                  Yes, sure. You are welcome.

                                1 Solution

                                Creation Date Importance Sort by

                                Fixed: