Current filter:
                                You should refresh the page.
                                  • Hello,

                                    as the title states, how can I disable CodeRush Roslyn for the ASP-parts of projects, so that no warnings occure anymore.
                                    It's really annoying and not helpful... :-/ (see attached picture)

                                    I hope you have a solution.

                                    Best regards,
                                    Michail

                                • Eugene R (DevExpress) 11.04.2016

                                  Hi Michail,

                                  Thank you for contacting us and informing about this problem.
                                  I was able to reproduce it in a simple ASP.NET project.
                                  We will make the corrections and let you know of our results.

                                  Now, as a quick solution, I recommend you disable the use of naming convention for Types in Code Analysis.
                                  For this, select the CodeRush->Options menu item. Then, navigate to the Editor->Visual Basic->Naming Conventions options in the options list. Finally, find the naming convention for Types and disable the "Use In Code Analysis" option.
                                  I expect this should help, because in my test scenario, the naming convention for the Types was the single one that added the mess into the aspx file. If this does not help, disable the 'Detect naming rules violations' option on the same option page.

                                  Michail, I've recorded a video illustrating how to disable this naming convention.
                                  Please contact us if you face any difficulties.

                                • Michail 11.04.2016

                                  In the video you only have activated it for "Types", but I have all naming conventions enabled for Visual Basic.
                                  And only disabling "types" doesn't change anything (same number of warning messages). :-/

                                  And I also have CRRSP01 (Spelling) errors too in the ASPX-files except code behind. Not only the  CRR1000 erros. ;-)

                                  So, I have to wait for your corrections and disable both (spell checker and naming conventions).

                                • Michail 11.04.2016

                                  I played a little with the naming convention options and now I have following options enabled, so no CRR1000 errors are shown. (see attached picture)

                                  Only the CRRSP01 errors remain...
                                  In "Options -> Editor -> All Languages -> Spell Checker" I disabled also in "Identifiers":
                                  - Public members
                                  - Private members
                                  --> now the errors are gone.

                                  But, it's only a quick solution. ;-)

                                • Eugene R (DevExpress) 11.04.2016

                                  Hi Michail,

                                  Nice to hear that you have found the solution.

                                  From your initial post, I see that only errors from Naming Conventions are present in the Error Window.
                                  I have not noticed the Spell Checker error reports in aspx files while testing either.

                                  I've created a separate ticket regarding this problem on your behalf: CodeRush Roslyn - Spell Checker displays errors in aspx-files, so we can process this problem in the most effecient manner.

                                1 Solution

                                Creation Date Importance Sort by

                                Fixed: