Current filter:
                                You should refresh the page.
                                  • Hi,

                                    I've tried performing the steps set out in the tutorial on one of my projects, but on the step - Prepare Mobile Application for the First Run , where you need to add the [Project].Module to MobileApplication.cs I get stuck.

                                    My [Project].Module Components aren't available in the Toolbox. Only see XAF Modules and XAF Security.

                                    All the other projects - Web, Win etc all has the Module available in the toolbox.
                                    What do I need to do to get this working?

                                    Thanks. 

                                1 Solution

                                Creation Date Importance Sort by

                                Hello Jean,

                                Visual Studio must discover these modules automatically, and this functionality is not related to DevExpress. If this does not work as expected (this may happen sometimes in such complex software like IDE), you can use standard solutions for Visual Studio available in public community resources like StackOverFlow.

                                To save you time, let me iterate the most popular options:
                                - Make sure that the project in which you invoke the Toolbox has the same or compatible "Target framework" setting as the project containing your target component (see this under the project Properties dialog)
                                - Close the Application Designer for the MobileApplication.xx file, rebuild your solution projects and try to see the Toolbox again.
                                - Close and reopen Visual Studio.
                                - Use the Repair Toolbox command in the context menu of the Toolbox
                                - Add the MainDemoModule component manually as per MSDN: https://msdn.microsoft.com/en-us/library/ms165355%28v=vs.100%29.aspx

                                You can find more information on this on the Web. I hope this helps.

                                Show all comments
                                • Matt Holliday 04.25.2016

                                  Hi Jean,

                                  I had to change the Target Framework of the Data Service Project from 4.0 to 4.5 as this is what my Module was using.

                                • Dennis (DevExpress) 04.25.2016

                                  Thanks for your input, Matt

                                • Otavio Laskosky 1 06.14.2016

                                  for what did you need to put in Target framework? 

                                • Dennis (DevExpress) 06.14.2016

                                  @Otavio: Your question is not quite clear. As was discussed above, the Target Framework change can be needed for the components to appear in Visual Studio toolbox.

                                • Otavio Laskosky 1 06.14.2016

                                  Matt changed the Target Framework for appear components in Visual Studio toolbox. I wonder to which he changed (Example 4.6.01).  

                                • Dennis (DevExpress) 06.14.2016

                                  As he wrote, he changed it to 4.5, because HisSolutionName.Module project was built for .NET 4.5. See also the instruction from my answer above:
                                  >>Make sure that the project in which you invoke the Toolbox has the same or compatible "Target framework" setting as the project containing your target component (see this under the project Properties dialog)

                                • Otavio Laskosky 1 06.14.2016

                                  "4.0 to 4.5 as this is what my Module was using".
                                   He wrote WAS USING. but ultimately, none of them worked, much less their descriptions.

                                • Dennis (DevExpress) 06.14.2016

                                  @Otavio: I've created a separate ticket on your behalf (T391938: Problems with adding a shared module from the Visual Studio toolbox). It has been placed in our processing queue and will be answered shortly.

                                • Otavio Laskosky 1 06.14.2016

                                  Thank you