Current filter:
                                You should refresh the page.
                                Support Center
                                0
                                  • I have an 12.1.5 web application. I have an object project which has a one-to-many association with customers. When I add a new project, I click on the binoculars to bring up the customer popup to choose a customer. When I am in development mode it works. In the published version on the server, it does not work. What am I missing?

                                Show all comments
                                • Hi Jon,

                                  I'm afraid the information you provided is insufficient to diagnose this issue. It is possible that an exception has occurred during a callback. Please review your application log file. I hope it helps.

                                • Jon Jaroska 07.30.2012

                                  There is no exception in the log file. In fact every single time there is a binoculars beside a field to do a look up, it does not come up. Also, the create new record button does not work either. This works when I am running in development mode but not on the deployed application. I have copied ALL binaries to the destination and still no success.

                                • Hi Jon,

                                  Thank you for your reply. Our attempts to reproduce this issue were unsuccessful. To research this issue we need a sample project that we can build and run locally. Please provide us with a sample and detailed instructions on how to reproduce the issue, including the deployment steps. Also, specify the web server and browser versions you are using.

                                • Jon Jaroska 07.31.2012

                                  Here it is. I tried it using chrome and ie9. to publish i made sure all dev dll's were copy local true and then i right cluck the web project and click publish with ftp mode and delete all files first. also here is a test site. http://crm.glxyinc.com. goto projects, edit a project, and then try to add a new customer from that project screen.

                                • Thank you for your project. We have tried to reproduce the issue after deploying the application to IIS, but to no avail. See the attached video. Let us know if there are additional steps required.

                                • Jon Jaroska 08.01.2012

                                  I think I figured it out. When I go to IIS and browse, it works great. When I go to the website from the outside world with the ip address, it also works great. I have dns setup to point to the ip address with a frame re-direct. Going to it with the dns name does not work. You can see for yourself. Use 165.236.143.8 and use the username demo and the password demo. Then try the same thing using http://crm.glxyinc.com. You will see it does not work. I also believe that I have another ticket that has to do with formatting where the frame re-direct is also causing that problem. What is the next step?

                                • Konstantin M (DevExpress) 08.01.2012

                                  I regret to inform you that I cannot reproduce this behavior.
                                  I have successfully opened the http://crm.glxyinc.com in IE9 and logged on
                                  as a demo/demo user. The 'New' button works as expected in the 'Attachment' ListView (a new DetailView with a new attachment is shown) and it works as expected for the 'New' action of the 'Project' editor (a popup DetailView with a new project is shown). Then I used the '165.236.143.8' address and repeated this test with the same result: all works as expected.

                                  Please describe how to reproduce this behavior in greater detail. You can use Jing to make a video. I am looking forward to hearing from you.

                                • Jon Jaroska 08.03.2012

                                  Ok. I changed the dns back to frame re-direct. try http://crm.glxyinc.com now. I will leave it broken until you can re-produce

                                • Konstantin M (DevExpress) 08.05.2012

                                  I have reproduced the problem in your deployed application.
                                  It seems that the problem is caused by the use of IFrames. Here is what my IE9 browser says:

                                  SCRIPT5: Access is denied.
                                  165.236.143.8, line 1 character 1
                                  Please look at the attached image. It shows the developer tools panel with the error in scripts.

                                  Here is what FireFox says:

                                  Unsafe JavaScript attempt to access frame with URL http://crm.glxyinc.com/ from frame with URL http://165.236.143.8/#ShortcutViewID=Opportunity_DetailView&ShortcutObjectKey=d1e58406-89d6-4cd4-ac86-00bb4727ebad&ShortcutObjectClassName=CrmExpress.Module.BusinessObjects.Opportunity&Shortcutmode=Edit. Domains, protocols and ports must match.
                                  dxo.Click.AddHandler.e.processOnServer

                                  and the Google Chrome says:

                                  Error: Permission denied to access property 'PopupWindowCallbackPanel'
                                  if(scriptElement.readyState == "loaded") {

                                  I see that you are using custom templates with IFrames. In this case, I suggest you review the Unsafe JavaScript attempt to access frame with URL article. Currently, we have not tested customized templates with frames and cannot provide you with advice when this approach is used.

                                • Jon Jaroska 08.19.2012

                                  I migrated away from iframes and it works! Thanks.

                                • Konstantin M (DevExpress) 08.20.2012

                                  I am glad to hear that the problem has been successfully resolved.

                                • Jon Jaroska 08.24.2012

                                  can you provide a solution to this so i can flag it as solved?

                                1 Solution

                                Creation Date Rating Importance Sort by
                                -1

                                I see that you are using custom templates with IFrames. In this case, I suggest you review the Unsafe JavaScript attempt to access frame with URL article. Currently, we have not tested customized templates with frames and cannot provide you with advice when this approach is used.

                                If you need additional product information, write to us at info@devexpress.com or call us at +1 (818) 844-3383

                                FOLLOW US

                                DevExpress engineers feature-complete Presentation Controls, IDE Productivity Tools, Business Application Frameworks, and Reporting Systems for Visual Studio, along with high-performance HTML JS Mobile Frameworks for developers targeting iOS, Android and Windows Phone. Whether using WPF, ASP.NET, WinForms, HTML5 or Windows 10, DevExpress tools help you build and deliver your best in the shortest time possible.

                                Copyright © 1998-2017 Developer Express Inc.
                                All trademarks or registered trademarks are property of their respective owners