Current filter:
                                You should refresh the page.
                                Support Center
                                0
                                  • I had created a project with target framework as 2.0 using VS2008 and Devexpress grid control 8.3.5. After upgrading our IDE we have now started using VS2010.
                                    When i open the same project, i cannot get to view the forms. I get a message

                                    "This method explicitly uses CAS policy, which has been obsoleted by the .NET Framework. In order to enable CAS policy for compatibility reasons, please use the NetFx40_LegacySecurityPolicy configuration switch. Please see http://go.microsoft.com/fwlink/?LinkID=155570 for more information. "

                                    The call stack of the error comes to
                                    at System.Security.SecurityManager.ResolvePolicy(Evidence evidence)
                                    at DevExpress.Data.Helpers.SecurityHelper.IsPermissionGranted(IPermission permission)
                                    at DevExpress.Utils.Design.DXAssemblyResolverEx.Init()
                                    at DevExpress.XtraEditors.XtraForm..cctor()

                                    Could you please help for the issue.

                                0

                                Hi Jayesh,

                                Thank you for your message.

                                To be able to use our components in VS 2010, you need to install the 10.1/10.2 version.
                                Previous versions are not supported by VS 2010.

                                We hope that you find this information helpful.

                                Thanks,
                                Svetlana

                                0

                                Is there no other way. Currently i cannot upgrade to Devexpress version 10.x since this involves a lot of modifications in a lot of projects which is not affordable at this point of time. Pls advise if there is a work-around of it.

                                0

                                Hi Jayesh,

                                The problem with CAS policy is known to us. Please upgrade to the 8.3.8 version where this problem is eliminated. Also, please refer to the following issue for a possible workaround: Components are incompatible with .NET 4.0 / VS2010 CTP / Beta 1

                                Thanks,
                                Ted

                                To start a chat you should create a support ticket


                                If you need additional product information, write to us at info@devexpress.com or call us at +1 (818) 844-3383

                                FOLLOW US

                                DevExpress engineers feature-complete Presentation Controls, IDE Productivity Tools, Business Application Frameworks, and Reporting Systems for Visual Studio, along with high-performance HTML JS Mobile Frameworks for developers targeting iOS, Android and Windows Phone. Whether using WPF, Silverlight, ASP.NET, WinForms, HTML5 or Windows 8, DevExpress tools help you build and deliver your best in the shortest time possible.

                                Copyright © 1998-2014 Developer Express Inc.
                                All trademarks or registered trademarks are property of their respective owners