Current filter:
                                You should refresh the page.
                                Support Center
                                0
                                  • Same issue as question Q264131

                                    -Winforms project
                                    -Upgraded from VS 2008 with DevEx 9.1.5 to VS 2010 with DevEx 10.1.6 using the DevEx project converter.
                                    -DevExpress 9.1.5 is still installed because of older VS 2008 projects.
                                    -The error occurs in control derived from UserControl which contains any number of controls with a button like LookUpEdit, ButtonEdit etc.-
                                    -We are NOT using TFS but Subversion as source code control
                                    -MessageBox with the following info: "Code generation for property 'Buttons' failed. Error was: 'Object reference not set to an instance of an object.' "
                                    -If I create a new UserControl in the same project in VS 2010 with DevEx 10.1.6 and tries to place a LookUpEdit on it, it fails with the same message.
                                    -If I create a new PROJECT with a usercontrol and then place a LookUpEdit on it, it works fine.

                                    Obviously it's got something to do with the project and not the .Designer.cs code generated by earlier versions of DevEx since a new usercontrol in the same project has the exact same problem as usercontrols with designer code generated by previous versions of DevEx/VS

                                    I have cleaned the solution, deleted the bin and obj directories and tried again, but the same error persists. When searching through all files in the project for the string "9.1.5" the files found can be seen in the attached screenshot.

                                    Is it not possible to have two versions of DevExpress installed? I know this was not possible in the past, but I'm sure I read somewhere that it was now supported.

                                0

                                Hi Trygve ,

                                Indeed, this problem is caused by assemblies conflict. You can have two different major versions installed on the same machine. But the requirement is that only one version can be used in the same project. Please expand the project's references node and ensure that it refers only to version 10.1.6 assemblies.

                                Please try to temporary remove all files that contain a reference to version 9.1.5. If it is possible, you can send your project to us. We will try to find the cause.

                                Thanks
                                Dimitros

                                If you need additional product information, write to us at info@devexpress.com or call us at +1 (818) 844-3383

                                FOLLOW US

                                DevExpress engineers feature-complete Presentation Controls, IDE Productivity Tools, Business Application Frameworks, and Reporting Systems for Visual Studio, along with high-performance HTML JS Mobile Frameworks for developers targeting iOS, Android and Windows Phone. Whether using WPF, Silverlight, ASP.NET, WinForms, HTML5 or Windows 8, DevExpress tools help you build and deliver your best in the shortest time possible.

                                Copyright © 1998-2014 Developer Express Inc.
                                All trademarks or registered trademarks are property of their respective owners