Current filter:
                                You should refresh the page.
                                Support Center
                                0
                                  • Hello,

                                    In order to prevent applications that exist in subdirectories to inherited devexpress settings I created a location section in my web.config file (see http://msdn.microsoft.com/en-us/library/b6x6shw7.aspx).

                                    it looks like:
                                     <location path="." inheritInChildApplications="false">
                                        <system.web>
                                          <compilation defaultLanguage="vb" debug="true" targetFramework="4.0">
                                            <assemblies>
                                              <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
                                              <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
                                              <add assembly="DevExpress.Web.v11.1, Version=11.1.8.0, Culture=neutral, PublicKeyToken=B88D1754D700E49A" />
                                              <add assembly="DevExpress.Data.v11.1, Version=11.1.8.0, Culture=neutral, PublicKeyToken=B88D1754D700E49A" />
                                              <add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
                                            </assemblies>
                                          </compilation>
                                          <httpModules>
                                            <add type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v11.1, Version=11.1.8.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" name="ASPxHttpHandlerModule" />
                                            <add name="ASPxHttpHandlerModule" type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v11.1, Version=11.1.8.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />
                                          </httpModules>
                                        </system.web>
                                      </location>

                                    When I change a web page the web.config file is updated and a duplicated httpModules section is created and the web.config need to be edited in order to remove it.
                                        <httpModules>
                                          <add type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v11.1, Version=11.1.8.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" name="ASPxHttpHandlerModule" />
                                        </httpModules>

                                    Can you tell me how to prevent the duplicated section from being created?

                                    Best regards

                                    Jacques Dagousset

                                    Steps to Reproduce:

                                    - use VS 2010 Premium SP1

                                    - open the web.config file then make sure there is no HttpModules section at line 56

                                    - open the master page

                                    - immediately the web.config file will be modified to add a HttpModules section at line 56 then the file will be automatically closed

                                0

                                Hello Jacques,

                                Thank you for contacting us. I have reviewed the information your provided and it seems that we do have an immediate solution for you.
                                We will examine this behavior and do our best to provide a fix for you, should we confirm the bug.

                                Just in case, please check the following point:
                                I see that duplicated entries have the same definition just with re-ordered attributes. Please define the "ASPxHttpHandlerModule" entry in the same format as created by Visual Studio as duplicate.
                                Check whether or not the duplicate entry is still added automatically.

                                Thanks,
                                Mike

                                0

                                I only kept the following line in the existing section:
                                        <add type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v11.1, Version=11.1.8.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" name="ASPxHttpHandlerModule" />

                                But as soon I swith to an aspx page my web.config is changed and the same duplicated line is created.

                                I also found that if the web.config file is already opened in VS 2010 then it will be closed without any user confirmation.

                                It also seems that a web.config under sourcesafe control might be written without being checked out. I am not able to reproduce this.

                                Jacques

                                0

                                Hi Jacques,

                                It is very likely that our ASP.NET designer does not correctly recognize the location option and thus adds http handler registration automatically. For now I see only a single solution - manually remove http modules registrations added by the designer. Meantime, would you please post here a simple sample project where we can see exactly your issue?

                                Thanks,
                                Plato

                                0

                                Hello,

                                I uploaded a project showing the problem.
                                In order to reproduce:
                                - use VS 2010 Premium SP1
                                - open the web.config file then make sure there is no HttpModules section at line 56
                                - open the master page
                                - immediately the web.config file will be modified to add a HttpModules section at line 56 then the file will be automatically closed

                                Best regards

                                Jacques Dagousset

                                Promodag.com - Incident Devexpress.zip
                                0

                                Hi Jacques,

                                Adding the DX Http Module to web.config is an expected behavior. If you open a page in a Designer mode and this page contains our controls, they automatically register our Http Module in web.config. We do this to avoid possible malfunctions of web pages in cases when a user forgets to register the Http Module. At the same time, I think that our routines should not close the web.config file if it was previously open. This seems to be a separate issue that is not directly related to your original inquiry. I am going to create a separate ticket for it, if you do not mind.

                                Regards,
                                Serge

                                0

                                Hi Serge,

                                The problem is not about automatically registering your Http Module in web.config. The problem is about registering it twice as it is already registered inthe location section.

                                Regards

                                Jacques

                                0

                                Jacques,

                                Thank you for the clarification. Now, I better understand your concerns. Yes, I have managed to replicate this side-effect. We will discuss it with the team to figure out why it takes place. Please bear with us.

                                Regards,
                                Serge

                                0

                                Hi Jacques,

                                We have had a long and interesting discussion about this case with the team. Together, we have come to the conclusion that it is impossible to fully cover all possible scenarios of using a <location> tag. Imagine that you can set up a reference to our HTTP handler module in a specific location, but miss it in another location, while both locations refer to pages containing our ASP.NET controls. In this case, missing a reference in the second location will obviously result in errors when opening the pages residing in this location. This is the main reason why we put a reference to our HTTP handler module in the main section. If you wish to use a custom scenario, it is necessary to adjust these references as your needs dictate.

                                I hope this explanation makes our position clear.

                                Regards,
                                Serge

                                To start a chat you should create a support ticket


                                If you need additional product information, write to us at info@devexpress.com or call us at +1 (818) 844-3383

                                FOLLOW US

                                DevExpress engineers feature-complete Presentation Controls, IDE Productivity Tools, Business Application Frameworks, and Reporting Systems for Visual Studio, along with high-performance HTML JS Mobile Frameworks for developers targeting iOS, Android and Windows Phone. Whether using WPF, Silverlight, ASP.NET, WinForms, HTML5 or Windows 8, DevExpress tools help you build and deliver your best in the shortest time possible.

                                Copyright © 1998-2014 Developer Express Inc.
                                All trademarks or registered trademarks are property of their respective owners